ImportError when Remote Debugging since 2.7

  • 7
  • 52

Hi,

Just updated to 2.7 and have an issue with the remote debugger which has always worked for over a year. I get the following trackback:

Traceback (most recent call last):
File "/Users/das05/workspace/cats-hack-bundle/cats/business/validation/validation.py", line 61, in wrapper
return wsgi_app(environ, start_response)
File "/Users/das05/.virtualenvs/cats-hack-bundle/lib/python2.7/site-packages/flask/app.py", line 1689, in wsgi_app
response = self.make_response(self.handle_exception(e))
File "/Users/das05/.virtualenvs/cats-hack-bundle/lib/python2.7/site-packages/flask/app.py", line 1687, in wsgi_app
response = self.full_dispatch_request()
File "/Users/das05/.virtualenvs/cats-hack-bundle/lib/python2.7/site-packages/flask/app.py", line 1360, in full_dispatch_request
rv = self.handle_user_exception(e)
File "/Users/das05/.virtualenvs/cats-hack-bundle/lib/python2.7/site-packages/flask/app.py", line 1358, in full_dispatch_request
rv = self.dispatch_request()
File "/Users/das05/.virtualenvs/cats-hack-bundle/lib/python2.7/site-packages/flask/app.py", line 1344, in dispatch_request
return self.view_functions[rule.endpoint](**req.view_args)
File "/Users/das05/workspace/cats-hack-bundle/cats/server/demoapp/demoapp_views.py", line 50, in demo_home
products = json.dumps(product_data.get_products(catalogue)),
File "/Users/das05/workspace/cats-hack-bundle/cats/server/presets/product_data.py", line 101, in get_products
return process_nodes(root_node, just_bundles=just_bundles)
File "/Users/das05/workspace/cats-hack-bundle/cats/server/presets/product_data.py", line 89, in process_nodes
_process_node(root_node)
File "/Users/das05/workspace/cats-hack-bundle/cats/server/presets/product_data.py", line 68, in _process_node
from pydev import pydevd
ImportError: No module named pydev


I have added the debug egg to the path and imported pydev as I have for previous versions like so:

import sys
sys.path.append("/Applications/PyCharm.app/pycharm-debug.egg")
from pydev import pydevd
pydevd.settrace('localhost', port=14999, stdoutToServer=True, stderrToServer=True)

The settings match in PyCharm, and I even tried recreating them and using it again and I still get the ImportError.

Any help would be really appreciated.

I am running Mac OS X Mountain Lion and version 2.7 of PyCharm.
Worked perfectly. Thanks for your reply!

Same problem here, on Windows :(

Please try: import pydevd
instead of
from pydev import pydevd

I have, even after trying easy_install pycharm-debug.egg, which ran successfully

python -c "import pydevd"

Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: No module named pydevd

Is it the same python? And which one is it? (I mean the version)

'pycharm-debug.egg' folder in site-packages turned out to actually be empty, removed and easy_install ran again and it's all working now, thank you.