pycharm heats up my computer while idle

  • 6
  • 20

i was sitting here with pycharm open, doing nothing watching tv in the background .. my leg started getting hot .. i opened the task manager and i see pycharm is putting my pc at 25% ... it was not supposed to be doing anything at all .. it was really heating up so much my pc was getting hotter and hotter, and my fan was spinning higher and higher speed ... i closed pycharm and the fan and temp went down .. what the heck is it doing?
One possibility is index corruption, which may cause PyCharm's code inspections to never complete. You can rebuild the indices using the File | Invalidate Caches menu item.

If this doesn't help, you can capture a CPU snapshot of PyCharm's high CPU usage as described in http://devnet.jetbrains.com/docs/DOC-1212 and send it to us for investigation.
--
Dmitry Jemerov, Chief Technology Officer, JetBrains

what version of YourKit should be used for PyCharm 3.x?

As always, the one which is bundled in the distribution archive. You don't need to install YourKit separately.
--
Dmitry Jemerov, Chief Technology Officer, JetBrains

I'm sorry, the distribution archive of what?

Of PyCharm. The yjpagent library is included in every distribution; you just need to enable it by editing the VM options or info.plist file.
--
Dmitry Jemerov, Chief Technology Officer, JetBrains

I'm running on a 64-bit Windows. Does it matter? The instructions pointed to at the top of this thread (http://devnet.jetbrains.com/docs/DOC-1212) say:

1. If you are using PyCharm on Windows under a 64-bit JVM, please follow instructions below. Otherwise please proceed to the following step.

Please obtain the library(64-bit for 64-bit JVM) version from the YourKit Java Profiler distribution (you need Linux .zip download of 8.x version containing library versions for different operating systems: Linux, Mac, Solaris, Windows). You will find libraries in "bin" folder of the distribution. Copy (or replace) yjpagent library in PYCHARM_HOME\bin with the appropriate version. Use 8.x YourKit version for PyCharm, otherwise toolbar buttons will not appear!


That's what I was following.