TextMate Bundles

  • 1
  • 6

I just installed PyCharm and found that I can use Text Mate bundles. It is not documented if I can use Text Mate version 1 or version 2 (alfa) of bundle format. I assume it is Version 1.

I have TextMate license, so I selected markdown bundle directory and got error message. I tried make bundle and I got the same error message.

Since I use TextMate version 2 and keeping version 1 of the app results in a messy right click menu in Finder I decided I don't keep v1 of the application. Instead I simply extracted bundles into a folder:

~/Library/Application Support/TextMateBundles/

so, when I tried to select a bundle I selected bundles paths:

~/Library/Application Support/TextMateBundles/Make.tmbundle
~/Library/Application Support/TextMateBundles/Markdown.tmbundle

Error message:

Can't read bundle from /Users/sergei/Library/Application Support/TextMateBundles/Make.tmbundle
At the moment TextMate bundles plugin can't parse binary bundles. Please, try to choose sources of markdown bundle: https://github.com/textmate/markdown.tmbundle