OpenJDK 7 (officially) supported?

  • 1
  • 15

I noticed that with the 3.x release a change was made to the requirements as indicated on the download page for the Linux version (please correct me if I am wrong). Where this initially merely indicated Oracle Java 1.6, it now also lists OpenJDK 7. Both are listed as equal: "Oracle JRE 1.6+ or OpenJDK 1.7+".

However when running pycharm.sh I notice the identical message as for the PyCharm 2.x releases: "WARNING: You are launching the IDE using OpenJDK Java runtime". Indicating one should use the Oracle JDK before reporting problems...

Is this message outdated for the 3.x releases or is it still that the OpenJDK is listed as a requirement but not officially supported?
Question is not answered.
Hi Thijs, the message is outdated. It will be removed in future versions. OpenJDK 7 is currently mentioned as supported as there are no known problems with it. This may change in future.