Pycharm ignoring changed default port for Django development server

  • 0
  • 4

Some process is using 8000 on my local win7 work station so I have changed the default Django configuration to us a different port (9123). But when I go to Pycharm's django management command menu and run the runnserver command with no command line parameters the pycharm tries to start the development server on 8000.

I have tried setting up other Pycharm configurations with the new port number, but same result.

The only way I can the server to load on the new port is everytime I run the server to manually add the port number parameter by pressing shift when I select the runnserver choice on the management command dropdown (each time I start the server).

Any suggestions?

Mark