ssh keys & git/stash on Linux

  • 1
  • 2

hi

i'm having trouble testing and cloning remote repos in pycharm.

i have the ssh keys in $HOME/.ssh

i'm using JDK 1.7 on a Centos machine

does anyone have any ideas? a normal git clone from the command line works fine so i know it's not a permissions problem

cheers
P


this is the stack trace:


2014-04-30 17:27:51,887 [ 8774] INFO - git4idea.commands.GitHandler - Cloning into 'pycharm-test'...
2014-04-30 17:27:52,448 [ 9335] INFO - git4idea.commands.GitHandler - getLastSuccessful failed. handlerNo: 0, userName: git@stash, client: http://x.x.x.x:xxxxx/RPC2 (x's here for security purposes)
2014-04-30 17:27:52,449 [ 9336] INFO - git4idea.commands.GitHandler - java.lang.RuntimeException: Invocation failed Connection refused
2014-04-30 17:27:52,449 [ 9336] INFO - git4idea.commands.GitHandler - at org.jetbrains.git4idea.ssh.GitSSHXmlRpcClient.getLastSuccessful(GitSSHXmlRpcClient.java:223)
2014-04-30 17:27:52,450 [ 9337] INFO - git4idea.commands.GitHandler - at org.jetbrains.git4idea.ssh.SSHMain.authenticate(SSHMain.java:196)
2014-04-30 17:27:52,450 [ 9337] INFO - git4idea.commands.GitHandler - at org.jetbrains.git4idea.ssh.SSHMain.start(SSHMain.java:157)
2014-04-30 17:27:52,451 [ 9338] INFO - git4idea.commands.GitHandler - at org.jetbrains.git4idea.ssh.SSHMain.main(SSHMain.java:137)
2014-04-30 17:27:52,451 [ 9338] INFO - git4idea.commands.GitHandler - Caused by: java.net.ConnectException: Connection refused
2014-04-30 17:27:52,452 [ 9339] INFO - git4idea.commands.GitHandler - at java.net.PlainSocketImpl.socketConnect(Native Method)
2014-04-30 17:27:52,452 [ 9339] INFO - git4idea.commands.GitHandler - at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:339)
2014-04-30 17:27:52,453 [ 9340] INFO - git4idea.commands.GitHandler - at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:200)
2014-04-30 17:27:52,453 [ 9340] INFO - git4idea.commands.GitHandler - at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:182)
2014-04-30 17:27:52,453 [ 9340] INFO - git4idea.commands.GitHandler - at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
2014-04-30 17:27:52,454 [ 9341] INFO - git4idea.commands.GitHandler - at java.net.Socket.connect(Socket.java:579)
2014-04-30 17:27:52,454 [ 9341] INFO - git4idea.commands.GitHandler - at java.net.Socket.connect(Socket.java:528)
2014-04-30 17:27:52,454 [ 9341] INFO - git4idea.commands.GitHandler - at java.net.Socket.<init>(Socket.java:425)
2014-04-30 17:27:52,455 [ 9342] INFO - git4idea.commands.GitHandler - at java.net.Socket.<init>(Socket.java:208)
2014-04-30 17:27:52,455 [ 9342] INFO - git4idea.commands.GitHandler - at org.apache.xmlrpc.LiteXmlRpcTransport.initConnection(LiteXmlRpcTransport.java:149)
2014-04-30 17:27:52,455 [ 9342] INFO - git4idea.commands.GitHandler - at org.apache.xmlrpc.LiteXmlRpcTransport.sendXmlRpc(LiteXmlRpcTransport.java:81)
2014-04-30 17:27:52,456 [ 9343] INFO - git4idea.commands.GitHandler - at org.apache.xmlrpc.XmlRpcClientWorker.execute(XmlRpcClientWorker.java:72)
2014-04-30 17:27:52,456 [ 9343] INFO - git4idea.commands.GitHandler - at org.apache.xmlrpc.XmlRpcClient.execute(XmlRpcClient.java:194)
2014-04-30 17:27:52,457 [ 9344] INFO - git4idea.commands.GitHandler - at org.apache.xmlrpc.XmlRpcClient.execute(XmlRpcClient.java:185)
2014-04-30 17:27:52,457 [ 9344] INFO - git4idea.commands.GitHandler - at org.apache.xmlrpc.XmlRpcClient.execute(XmlRpcClient.java:178)
2014-04-30 17:27:52,457 [ 9344] INFO - git4idea.commands.GitHandler - at org.jetbrains.git4idea.ssh.GitSSHXmlRpcClient.getLastSuccessful(GitSSHXmlRpcClient.java:215)
2014-04-30 17:27:52,458 [ 9345] INFO - git4idea.commands.GitHandler - ... 3 more
2014-04-30 17:27:52,458 [ 9345] INFO - git4idea.commands.GitHandler - fatal: Could not read from remote repository.
2014-04-30 17:27:52,458 [ 9345] INFO - git4idea.commands.GitHandler - Please make sure you have the correct access rights
2014-04-30 17:27:52,459 [ 9346] INFO - git4idea.commands.GitHandler - and the repository exists.
(didn't realise the community was so dead in here)

SOLUTION: if anybody is having the same problem make sure that settings > git > SSH executable is set to 'Native' so it picks up your ~./ssh folder