YouTrack baseurl setup on Windows

  • 9
  • 76

I've installed YouTrack on Windows and by default the base url for it is http://localhost. Now I tried stoping service and changing it in install_dir/conf/server.xml, but it had no affect what so ever. Could it be done at all?
Question is not answered.
Also asked by Mert Nuhoglu  
You can set the base URL by the java parameter: -Djetbrains.youtrack.baseUrl=http://youtrack

Please look at the documentationfor details.

Okey parameters page found http://confluence.jetbrains.com/display/YTD4/YouTrack+Start+Java+Parameters.

Also if it is the only way to change baseUrl variable on Windows, then it seems pointless to allow this option in youtrack settings if it has no affect on anything.

Also regarding database location. Not clear how to change it and restore from backup. I see the parameter for database location, but if I change it, I get Exception.

UPDATE
1. Stoped service
2. Added variable
3. Started service

Summary no change.

Hello Eugene,

It's two different ways to change the baseURL. You can accomplish this from the Administration-> Settings as well. Could you please clarify, did you try this from the Settings?
Speaking of Java parameters way, did you add parameter to Tomcat's configuration as it says in documentation? If you cannot hit configuration page from command line, please launch it from Program Files-> YouTrack-> bin-> tomcat6w

I'll answer your second question under related thread, you've created.

Thank you.
Regards,

Andrey Tigay
YouTrack engineer

Could you please clarify, did you try this from the Settings?

Yes. I tried from there as well. Saved settings. Restarted service. No change.

did you add parameter to Tomcat's configuration as it says in documentation?

Yes. Did exactly as it is explained. Same thing. No change.

@andrey.tigay: did you try what you suggested yourself?

Eugene,

I've carefully investigated both cases once again and found an issue with the baseURL parameter- it couldn't be applied if it's passed as a Java parameter. Please, take a look at the issue http://youtrack.jetbrains.com/issue/JT-21648 .
Speaking of settings Base URL from Settings page, it can be saved correctly. May I ask you to change your Base URL from Settings-> Save configuration and attach a screenshot of the page?

Thank you.
Regards,

Andrey Tigay
YouTrack engineer

I will do that a bit later and yes I was able to save it, but it had no affect on the location change. I was still able to access YouTrack service only though http://localhost:80

Eugene,

Please note, that baseURL parameter affects only links in notifications. baseURL specifies the path to database.
URL address that's used to reach YouTrack from browser address bar, can be configured only from web server's configuration.
In your case, it's about Tomcat, and it uses 'hostname' parameter, that should be modified.

Thank you.
Regards,

Andrey Tigay
YouTrack engineer

Would that be the correct place(install_dir/YouTrack/conf/server.xml)?
<Host name="youtrack.local"  appBase="webapps"
    unpackWARs="false" autoDeploy="true"
    xmlValidation="false" xmlNamespaceAware="false">
</Host>

because itsn't working as well.

Eugene,

Unfortunately, no.
In general there are two available ways to solve such issues:
1. If your server is available from the internet, you have to configure the DNS name for the server.
2. If you server isn't available from the internet, please, configure DNS for the local network.

In my previous reply I've mentioned the general solution, because, unfortunately we cannot solve similar issues as it's not the YouTrack's responsibility. It should be configured on your side, I assume you it's better to contact your system administrator.
Regards,

Andrey Tigay
YouTrack engineer