Error when installing: "/lib64/ld-linux-x86-64.so.2: bad ELF interpreter: No such file or directory"

  • 1
  • 6

Hello,

I've been following this help file to install YouTrack on my server:

http://confluence.jetbrains.com/display/YTD5/Linux.+YouTrack+JAR+as+a+Service

Everything was fine up until step:

8. Run your newly created wrapper to test the installation:

/sbin/service youtrack start

When I executed the above command, I received the following output:


root@host http://forum.jetbrains.com/sbin# service youtrack start
Starting youtrack...
"/home/youtrack/standalone/bin/wrapper" "/home/youtrack/standalone/conf/wrapper.conf" wrapper.syslog.ident=youtrack wrapper.pidfile="/home/youtrack/standalone//youtrack.pid" wrapper.daemonize=TRUE
/etc/rc.d/init.d/youtrack: /home/youtrack/standalone/bin/wrapper: /lib64/ld-linux-x86-64.so.2: bad ELF interpreter: No such file or directory

Through some searching I found that sometimes the "bad ELF interpreter" warning is given when a system is missing 32-bit glibc, but I tried executing the following command:

sudo yum install glibc.i686

And the output said:

Package glibc-2.12-1.132.el6.i686 already installed and latest version
Nothing to do
Hi,

Sorry for short delay.
I assume, this is because if versions mismatch. Could you please, provide us with the output of these commands:
uname -a
java -version

What version of Tanuki Wrapper did you download - 32 or 64? What Linux distributive do you have?

Thank you.
Regards,

Andrey Tigay
YouTrack engineer